Learning Navigation and Site Champion Issues

Incident Report for SLI

Postmortem

Summary

On 28 May 2026, some customers were unable to use Learning Navigation and Site Champion in the SLI Commerce Console (tools.sli-systems.com). Service was restored the same day. The incident was closed on 29 May 2026.

We apologize for any inconvenience this caused.

Impact

Item Detail
Affected service SLI Commerce Console (tools.sli-systems.com)
Severity Major (Status Page)
Investigating (UTC) 28 May 2026, 03:19
Service restored (UTC) 28 May 2026, 06:57
Incident closed (UTC) 29 May 2026, 11:24
Duration ~3 hours 38 minutes

What Happened

Our team deployed an updated version of the SLI Commerce Console as part of planned maintenance. The deployment did not fully complete on the production server.

This incomplete deployment caused the following issues:

  • Learning Navigation failed and showed server errors because essential support files were missing.
  • Site Champion loaded correctly but displayed no data, as the configuration needed for external requests was missing.

Unfortunately, the problem was not automatically detected by our internal monitoring, and we were alerted to the issue through customer support reports.

Root Cause

A recent application update did not complete all required steps on our production environment. This caused errors in Learning Navigation and prevented Site Champion from displaying data correctly.

Resolution Actions

Our team identified the issue, applied a corrective update to the production environment, and confirmed that Learning Navigation and Site Champion were working again. We continued to monitor the platform after the fix.

Preventive Measures

‌1. Automated browser monitoring (SC/LN display real data)

2. HTTP monitoring on critical static files

Alerting

We have increased the scope and frequency of monitoring so similar issues are detected earlier and addressed before customers are affected.

Timeline (UTC)

Source: Status Page incident history.

‌28 May 03:19 - Investigating | Regressions in Tools Console Release -; mitigation in progress

28 May 06:50 - Identified | Fix implementation and validation underway

28 May 06:57 - Monitoring | Functionality restored; monitoring continues

29 May 11:24 - Resolved | Incident closed

Closing Statement

We are committed to strengthening deployment and monitoring so similar issues are detected internally before they affect customers. For questions, contact SLI Support.

Posted Jun 04, 2026 - 08:11 UTC

Resolved

This incident has been resolved.
Posted May 28, 2026 - 11:24 UTC

Monitoring

The issue has been fixed, and the affected functionality has been restored. We are continuing to monitor the platform to ensure the issue does not recur.
Posted May 28, 2026 - 06:57 UTC

Identified

## Update

The issue has been identified, and the team is continuing to work on implementing a solution. We will provide another update once the fix has been applied and validated.
Posted May 28, 2026 - 06:50 UTC

Investigating

We identified two separate regressions introduced in the tools-console-1-347.0 release deployed on May 27. These regressions are causing the Learning Navigation HTTP 500 issue and the empty Site Champion console issue.

The Infrastructure team is aware of the issue and mitigation work is in progress.
Posted May 28, 2026 - 03:19 UTC
This incident affected: SLI (Commerce Console (aka SLI Tools)).